• Защита информации
  • ИТ-поддержка
  • Автоматическое создание резервной копии настроек Mikrotik с отправкой на почту и FTP

    1. Настраиваем профиль для работы с почтой. Зайдем в меню Tools — Email и введем необходимые настройки:

      Для проверки работы почты можно использовать следующую команду:

      /tool e-mail send to=address@of.mail subject=test

      где address@of.mail — адрес вашей электронной почты

    2. Переходим к самому скрипту. Идем в меню System — Scripts — Add. Пример настроек:

      local d [/sys clock get date];
      local t [/sys clock get time];
      /export file="fullConfigScript.rsc";
      :delay 10s;
      
      /system backup save name="MikroTik.backup";
      :delay 15s;
      /tool e-mail send to="s.barabash@efsol.ru" subject "Atlantik MIkrotik 1st Fl $d $t" file="MikroTik.backup";
      :delay 10s;
      /tool e-mail send to="s.barabash@efsol.ru" subject "Atlantik MIkrotik 1st Fl $d $t" file="fullConfigScript.rsc"
      :delay 10s;
      /tool fetch mode=ftp upload=yes user="efsol" password="randompassword" src-path=fullConfigScript.rsc address="XXX.XXX.XXX.XXX" dst-path=fullConfigScript.rsc
      /tool fetch mode=ftp upload=yes user="efsol" password="randompassword" src-path=MikroTik.backup address="XXX.XXX.XXX.XXX" dst-path=MikroTik.backup
      					
    3. После отработки скрипта проверяем на почте и FTP:

    4. Настраиваем планировщик System — Scheduler — Add. Вводим время начала задачи, интервал запуска и в поле On Event указываем название скрипта для запуска. Пример настроек:

    Готово.

    Не нашли ответа на свой вопрос?
    Содержание